You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Test-Timer/Test-Timer-2.100.0.ebuild

37 lines
743 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=JONASBN
DIST_VERSION=2.10
inherit perl-module
DESCRIPTION="test module to test/assert response times"
LICENSE="Artistic-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
virtual/perl-Carp
dev-perl/Error
virtual/perl-Test-Simple
"
DEPEND="${RDEPEND}
>=dev-perl/Module-Build-0.300.0
virtual/perl-ExtUtils-MakeMaker
test? (
virtual/perl-File-Spec
virtual/perl-IO
dev-perl/Test-Fatal
>=virtual/perl-Test-Simple-1.302.111
)
"
PATCHES=("${FILESDIR}/${PN}-${DIST_VERSION}-prereqs.patch")
src_prepare() {
perl_rm_files t/author-* t/release-*
perl-module_src_prepare
}