You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Time-Duration/Time-Duration-1.200.0.ebuild

27 lines
585 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=NEILB
DIST_VERSION=1.20
inherit perl-module
DESCRIPTION="Rounded or exact English expression of durations"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x86-linux ~x64-macos"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="virtual/perl-Exporter"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? ( virtual/perl-Test )
"
src_test() {
perl_rm_files t/release-{02_pod,03_pod_cover}.t
perl-module_src_test
}