You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/ZMQ-Constants/ZMQ-Constants-1.40.0.ebuild

27 lines
546 B

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DIST_AUTHOR=DMAKI
DIST_VERSION=1.04
inherit perl-module
DESCRIPTION="Constants for libzmq"
SLOT="0"
KEYWORDS="amd64 ~hppa ppc ppc64 sparc x86"
RDEPEND="
net-libs/zeromq
"
DEPEND="${RDEPEND}
>=virtual/perl-ExtUtils-MakeMaker-6.360.0
"
src_prepare() {
sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
die "Can't patch Makefile.PL for 5.26 dot-in-inc"
perl-module_src_prepare
}