You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/autobox/autobox-3.0.1-r1.ebuild

32 lines
580 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=CHOCOLATE
DIST_VERSION=v3.0.1
inherit perl-module
DESCRIPTION="Call methods on native types"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
>=dev-perl/Scope-Guard-0.210.0
>=virtual/perl-version-0.770.0
"
BDEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
>=dev-perl/IPC-System-Simple-1.250.0
>=dev-perl/Test-Fatal-0.14.0
)
"
src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
)
perl-module_src_compile
}