You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/PEAR-File_Archive/PEAR-File_Archive-1.5.5-r1....

34 lines
684 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
MY_PN="${PN/PEAR-/}"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Easily manipulate archives in PHP"
HOMEPAGE="https://pear.php.net/package/File_Archive"
SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="minimal"
RDEPEND="dev-lang/php[bzip2,zlib]
dev-php/PEAR-MIME_Type
dev-php/PEAR-PEAR
!minimal? (
dev-php/PEAR-Mail_Mime
dev-php/PEAR-Mail
dev-php/PEAR-Cache_Lite
)"
S="${WORKDIR}/${MY_P}"
src_install() {
dodoc README
insinto /usr/share/php
doins -r File
}