You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.5.4.ebuild

29 lines
729 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
MY_PN="${PN/PEAR-/}"
DESCRIPTION="An API for talking to sieve (RFC 3028) servers"
HOMEPAGE="https://github.com/roundcube/Net_Sieve"
SRC_URI="https://github.com/roundcube/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE="sasl"
RDEPEND="dev-lang/php:*
dev-php/PEAR-PEAR
dev-php/PEAR-Net_Socket
sasl? ( dev-php/PEAR-Auth_SASL )"
S="${WORKDIR}/${MY_PN}-${PV}"
src_install() {
# Install into "Net" for backwards compatibility (that's where PEAR
# used to put things).
insinto /usr/share/php/Net
doins Sieve.php
}