You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/PEAR-VersionControl_SVN/PEAR-VersionControl_SVN-0.5...

21 lines
586 B

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit php-pear-r2
DESCRIPTION="Simple OO wrapper interface for the Subversion command-line client"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
RDEPEND=""
src_prepare() {
einfo "Patching SVN.php and SVN/Command.php to use proper paths by default"
sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN.php || die "sed failed"
sed -i -e 's:/usr/local:/usr:g' VersionControl/SVN/Command.php || die "sed failed"
default
}