You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/doctrine-instantiator/doctrine-instantiator-1.4.0...

41 lines
816 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_PN="${PN/doctrine-//}"
DESCRIPTION="Utility to instantiate objects in PHP without invoking their constructors"
HOMEPAGE="https://github.com/doctrine/instantiator"
SRC_URI="https://github.com/doctrine/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
IUSE=""
BDEPEND="dev-php/theseer-Autoload"
RDEPEND="dev-php/fedora-autoloader
>=dev-lang/php-7.2:*"
S="${WORKDIR}/${MY_PN}-${PV}"
src_prepare() {
default
phpab \
--output src/Doctrine/Instantiator/autoload.php \
--template fedora2 \
--basedir src \
src \
|| die
}
src_install() {
insinto /usr/share/php/
doins -r src/*
einstalldocs
}