You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/doctrine/doctrine-2.6.1.ebuild

30 lines
672 B

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
MY_P="${PN}2-${PV}"
DESCRIPTION="An object relational mapper for PHP"
HOMEPAGE="https://www.doctrine-project.org/"
SRC_URI="https://github.com/${PN}/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="2"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-lang/php-7.1:*[cli,pdo]"
DEPEND=""
S="${WORKDIR}/${MY_P}"
src_install() {
insinto /usr/share/php
doins -r lib/Doctrine
insinto /usr/share/php/Doctrine
exeinto /usr/share/php/Doctrine
doins bin/doctrine.php
doexe bin/doctrine
dosym ../share/php/Doctrine/doctrine /usr/bin/doctrine
}