You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/jsonlint/jsonlint-1.8.2.ebuild

42 lines
887 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="JSON Lint for PHP"
HOMEPAGE="https://github.com/Seldaek/jsonlint"
SRC_URI="https://github.com/Seldaek/jsonlint/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
dev-lang/php:*
dev-php/fedora-autoloader"
DEPEND="
test? (
${RDEPEND}
dev-php/phpunit
)"
src_prepare() {
default
if use test; then
cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
sed -i -e "s:__DIR__:'${S}/src/Seld/JsonLint':" "${S}"/autoload-test.php || die
fi
}
src_install() {
insinto "/usr/share/php/Seld/JsonLint"
doins -r src/Seld/JsonLint/. "${FILESDIR}"/autoload.php
dodoc README.md
}
src_test() {
phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
}