You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/pecl-eio/pecl-eio-2.0.4-r1.ebuild

25 lines
493 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PHP_EXT_NAME="eio"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS=( README.md )
USE_PHP="php7-3 php7-4"
inherit php-ext-pecl-r3
KEYWORDS="~amd64 ~x86"
LICENSE="PHP-3.01"
DESCRIPTION="PHP wrapper for libeio library"
LICENSE="PHP-3"
SLOT="0"
IUSE="debug"
src_configure() {
local PHP_EXT_ECONF_ARGS=("--with-eio" "$(use_enable debug eio-debug)" )
php-ext-source-r3_src_configure
}