You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/pecl-yaz/pecl-yaz-1.2.3.ebuild

29 lines
585 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PHP_EXT_NAME="yaz"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS=( README )
USE_PHP="php5-6 php7-0 php7-1 php7-2 php7-3 php7-4"
inherit php-ext-pecl-r3
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc x86"
DESCRIPTION="This extension implements a Z39.50 client for PHP using the YAZ toolkit"
LICENSE="BSD"
SLOT="0"
IUSE=""
DEPEND=">=dev-libs/yaz-3.0.2:0="
RDEPEND="${DEPEND}"
# Needs network access
RESTRICT="test"
PHP_EXT_ECONF_ARGS="--with-yaz=/usr"