You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-php/sebastian-code-unit-reverse.../sebastian-code-unit-reverse...

27 lines
657 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
MY_PN="${PN/sebastian-/}"
DESCRIPTION="Looks up which function or method a line of code belongs to"
HOMEPAGE="https://phpunit.de"
SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~s390 sparc x86"
IUSE=""
S="${WORKDIR}/${MY_PN}-${PV}"
RDEPEND="dev-php/fedora-autoloader
>=dev-lang/php-5.6:*"
src_install() {
insinto /usr/share/php/SebastianBergmann/CodeUnitReverseLookup
doins -r src/*
doins "${FILESDIR}/autoload.php"
}