You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-qt/assistant/assistant-5.15.2.ebuild

56 lines
1.1 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
QT5_MODULE="qttools"
inherit desktop qt5-build xdg-utils
DESCRIPTION="Tool for viewing on-line documentation in Qt help file format"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 ~arm arm64 ~hppa ppc64 ~sparc x86"
fi
IUSE=""
DEPEND="
~dev-qt/qtcore-${PV}:5=
~dev-qt/qtgui-${PV}
~dev-qt/qthelp-${PV}
~dev-qt/qtnetwork-${PV}
~dev-qt/qtprintsupport-${PV}
~dev-qt/qtsql-${PV}[sqlite]
~dev-qt/qtwidgets-${PV}
"
RDEPEND="${DEPEND}"
QT5_TARGET_SUBDIRS=(
src/assistant/assistant
)
src_prepare() {
sed -e "s/qtHaveModule(webkitwidgets)/false/g" \
-i src/assistant/assistant/assistant.pro || die
qt5-build_src_prepare
}
src_install() {
qt5-build_src_install
doicon -s 32 src/assistant/assistant/images/assistant.png
newicon -s 128 src/assistant/assistant/images/assistant-128.png assistant.png
make_desktop_entry "${QT5_BINDIR}"/assistant 'Qt 5 Assistant' assistant 'Qt;Development;Documentation'
}
pkg_postinst() {
qt5-build_pkg_postinst
xdg_icon_cache_update
}
pkg_postrm() {
qt5-build_pkg_postrm
xdg_icon_cache_update
}