You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-qt/qtdbus/qtdbus-5.15.2.ebuild

50 lines
849 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
QT5_MODULE="qtbase"
inherit qt5-build
DESCRIPTION="Qt5 module for inter-process communication over the D-Bus protocol"
SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/qtbase-${PV}-gcc11.patch.xz"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
fi
IUSE=""
DEPEND="
~dev-qt/qtcore-${PV}:5=
>=sys-apps/dbus-1.4.20
"
RDEPEND="${DEPEND}
dev-qt/qtchooser
"
QT5_TARGET_SUBDIRS=(
src/dbus
src/tools/qdbusxml2cpp
src/tools/qdbuscpp2xml
)
QT5_GENTOO_CONFIG=(
:dbus
:dbus-linked:
)
QT5_GENTOO_PRIVATE_CONFIG=(
:dbus
:dbus-linked
)
PATCHES=( "${WORKDIR}"/qtbase-${PV}-gcc11.patch ) # bug 752012
src_configure() {
local myconf=(
-dbus-linked
)
qt5-build_src_configure
}