You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-qt/qtdeclarative/qtdeclarative-5.15.2.ebuild

60 lines
1.3 KiB

# Copyright 2009-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
inherit python-any-r1 qt5-build
DESCRIPTION="The QML and Quick modules for the Qt5 framework"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
fi
IUSE="gles2-only +jit localstorage vulkan +widgets"
BDEPEND="${PYTHON_DEPS}"
# qtgui[gles2-only=] is needed because of bug 504322
DEPEND="
~dev-qt/qtcore-${PV}
~dev-qt/qtgui-${PV}:5=[gles2-only=,vulkan=]
~dev-qt/qtnetwork-${PV}
~dev-qt/qttest-${PV}
localstorage? ( ~dev-qt/qtsql-${PV} )
widgets? ( ~dev-qt/qtwidgets-${PV}[gles2-only=] )
"
RDEPEND="${DEPEND}
dev-qt/qtchooser
"
PATCHES=(
"${FILESDIR}/${PN}-5.14.2-QQuickItemView-fix-maxXY-extent.patch" # QTBUG-83890
"${FILESDIR}/${P}-gcc11.patch" # bug 752093
)
src_prepare() {
use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
qt_use_disable_mod localstorage sql \
src/imports/imports.pro
qt_use_disable_mod widgets widgets \
src/src.pro \
src/qmltest/qmltest.pro \
tests/auto/auto.pro \
tools/tools.pro \
tools/qmlscene/qmlscene.pro \
tools/qml/qml.pro
qt5-build_src_prepare
}
src_configure() {
local myqmakeargs=(
--
-qml-debug
)
qt5-build_src_configure
}