You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-qt/qtimageformats/qtimageformats-5.15.2.ebuild

31 lines
670 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit qt5-build
DESCRIPTION="Additional format plugins for the Qt image I/O system"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 ~arm arm64 ~hppa ppc64 ~sparc x86"
fi
IUSE="mng"
DEPEND="
~dev-qt/qtcore-${PV}
~dev-qt/qtgui-${PV}
media-libs/libwebp:=
media-libs/tiff:0
mng? ( media-libs/libmng:= )
"
RDEPEND="${DEPEND}"
src_configure() {
sed -e 's/qtConfig(jasper)/false:/' \
-i src/plugins/imageformats/imageformats.pro || die
qt_use_disable_config mng mng src/plugins/imageformats/imageformats.pro
qt5-build_src_configure
}