You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-qt/qtlocation/qtlocation-5.15.2-r1.ebuild

51 lines
1.1 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit qt5-build
DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 arm arm64 x86"
fi
IUSE=""
RDEPEND="
dev-libs/icu:=
~dev-qt/qtcore-${PV}
~dev-qt/qtdeclarative-${PV}
~dev-qt/qtgui-${PV}
~dev-qt/qtnetwork-${PV}
~dev-qt/qtpositioning-${PV}[qml]
~dev-qt/qtsql-${PV}
sys-libs/zlib
"
DEPEND="${RDEPEND}
~dev-qt/qtconcurrent-${PV}
"
QT5_TARGET_SUBDIRS=(
src/3rdparty/clipper
src/3rdparty/poly2tri
src/3rdparty/clip2tri
src/3rdparty/mapbox-gl-native
src/location
src/imports/location
src/imports/locationlabs
src/plugins/geoservices
)
PATCHES=( "${FILESDIR}"/${P}-qsg-render-thread-crash-{1,2}.patch ) # QTBUG-85260
src_configure() {
# src/plugins/geoservices requires files that are only generated when
# qmake is run in the root directory. Bug 633776.
mkdir -p "${QT5_BUILD_DIR}"/src/location || die
qt5_qmake "${QT5_BUILD_DIR}"
cp "${S}"/src/location/qtlocation-config.pri "${QT5_BUILD_DIR}"/src/location || die
qt5-build_src_configure
}