You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-qt/qtprintsupport/qtprintsupport-5.15.2.ebuild

47 lines
928 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
QT5_MODULE="qtbase"
VIRTUALX_REQUIRED="test"
inherit qt5-build
DESCRIPTION="Printing support library for the Qt5 framework"
SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/qtbase-${PV}-gcc11.patch.xz"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
fi
IUSE="cups gles2-only"
RDEPEND="
~dev-qt/qtcore-${PV}:5=
~dev-qt/qtgui-${PV}[gles2-only=]
~dev-qt/qtwidgets-${PV}[gles2-only=]
cups? ( >=net-print/cups-1.4 )
"
DEPEND="${RDEPEND}
test? ( ~dev-qt/qtnetwork-${PV} )
"
QT5_TARGET_SUBDIRS=(
src/printsupport
src/plugins/printsupport
)
QT5_GENTOO_CONFIG=(
cups
)
PATCHES=( "${WORKDIR}/qtbase-${PV}-gcc11.patch" ) # bug 752012
src_configure() {
local myconf=(
$(qt_use cups)
-opengl $(usex gles2-only es2 desktop)
)
qt5-build_src_configure
}