You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/ddplugin/ddplugin-1.0.3.ebuild

27 lines
555 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
USE_RUBY="ruby25 ruby26 ruby27 ruby30"
RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
inherit ruby-fakegem
DESCRIPTION="Provides plugin management for Ruby projects"
HOMEPAGE="https://github.com/ddfreyne/ddplugin/"
LICENSE="MIT"
SLOT="1"
KEYWORDS="~amd64"
IUSE=""
all_ruby_prepare() {
sed -i -e '/coverall/I s:^:#:' test/helper.rb || die
}
each_ruby_test() {
${RUBY} -Ilib:test:. -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
}