You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/fast_xs/fast_xs-0.8.0-r2.ebuild

47 lines
1.3 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
USE_RUBY="ruby24 ruby25 ruby26 ruby27"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
inherit ruby-fakegem
DESCRIPTION="fast_xs text escaping library ruby bindings"
HOMEPAGE="https://github.com/brianmario/fast_xs"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris ~x86-solaris"
IUSE=""
ruby_add_bdepend "test? ( dev-ruby/rack )"
RUBY_PATCHES=( "${P}+ruby-1.9.patch" )
each_ruby_configure() {
${RUBY} -Cext/fast_xs extconf.rb || die "extconf.rb failed"
${RUBY} -Cext/fast_xs_extra extconf.rb || die "extconf.rb failed"
}
each_ruby_compile() {
emake -Cext/fast_xs CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
cp ext/fast_xs/fast_xs$(get_modname) lib/ || die
emake -Cext/fast_xs_extra CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" V=1
cp ext/fast_xs_extra/fast_xs_extra$(get_modname) lib/ || die
}
each_ruby_test() {
# the Rakefile tries to run all the tests in a single process, but
# this breaks the monkey-patchers, we're forced to run them one by
# one.
for tu in test/test_*.rb; do
${RUBY} -Ilib $tu || die "test $tu failed"
done
}