You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/hashicorp-checkpoint/hashicorp-checkpoint-0.1.5-...

32 lines
590 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
USE_RUBY="ruby25 ruby26 ruby27"
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
inherit ruby-fakegem
DESCRIPTION="Internal HashiCorp service to check version information"
HOMEPAGE="https://www.hashicorp.com"
LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
# Tests require network
RESTRICT="test"
ruby_add_bdepend "
test? ( dev-ruby/rspec-its )
"
all_ruby_prepare() {
# remove bundler support
sed -i '/[Bb]undler/d' Rakefile || die
}