You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/nanotest/nanotest-0.9.4.1.ebuild

23 lines
486 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
USE_RUBY="ruby24 ruby25 ruby26 ruby27"
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
inherit ruby-fakegem
DESCRIPTION="Extremely mynymal test framework"
HOMEPAGE="https://github.com/mynyml/nanotest"
LICENSE="MIT"
KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 sparc x86"
SLOT="0"
IUSE=""
each_ruby_test() {
${RUBY} -I.:lib test/test_nanotest.rb || die
}