You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/net-http-pipeline/net-http-pipeline-1.0.1.ebuild

27 lines
568 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
USE_RUBY="ruby24 ruby25 ruby26 ruby27"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
inherit ruby-fakegem
DESCRIPTION="An HTTP/1.1 pipelining implementation atop Net::HTTP"
HOMEPAGE="http://docs.seattlerb.org/net-http-pipeline/"
LICENSE="MIT"
SLOT="1"
KEYWORDS="~amd64"
IUSE=""
RUBY_PATCHES=( ${PN}-accept-encoding.patch )
ruby_add_bdepend "
test? ( dev-ruby/minitest )
"
each_ruby_test() {
${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
}