You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-ruby/unf_ext/unf_ext-0.0.7.7-r1.ebuild

38 lines
809 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
USE_RUBY="ruby25 ruby26 ruby27 ruby30"
RUBY_FAKEGEM_RECIPE_TEST="none"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_EXTENSIONS=(ext/unf_ext/extconf.rb)
inherit ruby-fakegem multilib
DESCRIPTION="Unicode Normalization Form support library for CRuby"
HOMEPAGE="https://github.com/knu/ruby-unf_ext"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
IUSE="doc test"
ruby_add_bdepend "
test? (
>=dev-ruby/test-unit-2.5.1-r1
)"
all_ruby_prepare() {
sed -i -e '/bundler/,/end/ s:^:#:' Rakefile test/helper.rb || die
}
each_ruby_test() {
ruby-ng_testrb-2 test/test_*.rb
}