You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/abi-dumper/abi-dumper-1.1.ebuild

28 lines
587 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DESCRIPTION="Dump ABI of an ELF object containing DWARF debug info"
HOMEPAGE="https://github.com/lvc/abi-dumper"
SRC_URI="https://github.com/lvc/abi-dumper/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="dev-lang/perl"
RDEPEND="${DEPEND}
dev-libs/elfutils
dev-util/vtable-dumper"
src_compile() {
:
}
src_install() {
dodir /usr
perl Makefile.pl -install -prefix "${EPREFIX}/usr" -destdir "${D}" || die
einstalldocs
}