You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/ccls/ccls-0.20210330.ebuild

43 lines
750 B

# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
EGIT_REPO_URI="https://github.com/MaskRay/${PN}"
if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi
inherit cmake ${GIT_ECLASS}
DESCRIPTION="C/C++/ObjC language server"
HOMEPAGE="https://github.com/MaskRay/ccls"
if [[ ${PV} == *9999 ]] ; then
SRC_URI=""
else
SRC_URI="https://github.com/MaskRay/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
DEPEND="
dev-libs/rapidjson
sys-devel/clang:=
sys-devel/llvm:=
"
RDEPEND="${DEPEND}"
src_configure() {
local mycmakeargs=(
-DCCLS_VERSION=${PV}
-DUSE_SYSTEM_RAPIDJSON=ON
-DCLANG_LINK_CLANG_DYLIB=1
)
cmake_src_configure
}