You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/cookiecutter/cookiecutter-1.7.2-r1.ebuild

49 lines
1.3 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_USE_SETUPTOOLS="rdepend"
inherit distutils-r1
DESCRIPTION="Command-line utility to create projects from cookiecutters (project templates)"
HOMEPAGE="https://github.com/audreyr/cookiecutter"
SRC_URI="https://github.com/audreyr/cookiecutter/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/binaryornot-0.4.4[${PYTHON_USEDEP}]
>=dev-python/jinja-2.7[${PYTHON_USEDEP}]
<dev-python/jinja-3.0.0[${PYTHON_USEDEP}]
>=dev-python/click-7.0[${PYTHON_USEDEP}]
>=dev-python/poyo-0.5.0[${PYTHON_USEDEP}]
>=dev-python/jinja2-time-0.2.0[${PYTHON_USEDEP}]
>=dev-python/python-slugify-4.0.0[${PYTHON_USEDEP}]
>=dev-python/requests-2.23.0[${PYTHON_USEDEP}]
>=dev-python/six-1.10[${PYTHON_USEDEP}]
<dev-python/markupsafe-2.0.0[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/freezegun[${PYTHON_USEDEP}]
dev-vcs/git )"
DOCS=( README.md HISTORY.md CONTRIBUTING.md )
PATCHES=(
"${FILESDIR}/test_cli-1.7.2.patch"
)
python_test() {
pytest -o addopts= || die
}