You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/crash/crash-9999.ebuild

41 lines
1023 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/crash-utility/crash.git"
SRC_URI="http://ftp.gnu.org/gnu/gdb/gdb-7.6.tar.gz"
EGIT_BRANCH="master"
inherit git-r3
else
SRC_URI="https://github.com/crash-utility/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
mirror://gnu/gdb/gdb-7.6.tar.gz"
KEYWORDS="-* ~alpha ~amd64 ~arm ~ia64 ~ppc64 ~s390 ~x86"
fi
DESCRIPTION="Red Hat crash utility; used for analyzing kernel core dumps"
HOMEPAGE="https://crash-utility.github.io/"
LICENSE="GPL-3"
SLOT="0"
IUSE=""
# there is no "make test" target, but there is a test.c so the automatic
# make rules catch it and tests fail
RESTRICT="test"
src_prepare() {
sed -i -e "s|ar -rs|\${AR} -rs|g" Makefile || die
ln -s "${DISTDIR}"/gdb-7.6.tar.gz . || die
default
}
src_compile() {
emake \
CC="$(tc-getCC)" \
AR="$(tc-getAR)" \
CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}