You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/cucumber-rails/cucumber-rails-1.8.0.ebuild

46 lines
1.2 KiB

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
USE_RUBY="ruby24 ruby25 ruby26"
# There are also cucumber features. They require a Rails project with
# factory girl which we don't have packaged yet.
RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
RUBY_FAKEGEM_GEMSPEC="cucumber-rails.gemspec"
inherit ruby-fakegem
DESCRIPTION="Executable feature scenarios for Rails"
HOMEPAGE="https://github.com/cucumber/cucumber/wikis"
LICENSE="Ruby"
KEYWORDS="~amd64"
SLOT="1"
IUSE=""
# Restrict tests since Appraisal is now mandatory to manage different
# rails versions, even for the specs.
RESTRICT="test"
#ruby_add_bdepend "
# test? (
# >=dev-ruby/ammeter-0.2.2
# >=dev-ruby/rspec-rails-2.7.0:2
# )"
ruby_add_rdepend "
>=dev-util/cucumber-3.0.2 <dev-util/cucumber-4
>=dev-ruby/nokogiri-1.8
>=dev-ruby/capybara-2.12:* <dev-ruby/capybara-4:*
>=dev-ruby/railties-4.2:* <dev-ruby/railties-7:*
>=dev-ruby/mime-types-2.0:* <dev-ruby/mime-types-4:*"
all_ruby_prepare() {
rm Gemfile || die
sed -i -e '/[Bb]undler/d' Rakefile || die
sed -i -e '/git ls/d' ${RUBY_FAKEGEM_GEMSPEC} || die
}