You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/cutter/cutter-1.12.0.ebuild

55 lines
1003 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
inherit qmake-utils xdg-utils python-single-r1
DESCRIPTION="A Qt and C++ GUI for radare2 reverse engineering framework"
HOMEPAGE="https://cutter.re https://github.com/radareorg/cutter/"
SRC_URI="https://github.com/radareorg/cutter/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="
${PYTHON_DEPS}
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
~dev-util/radare2-4.5.1
"
RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-1.10.3-python3-config.patch"
)
src_configure() {
local myqmakeargs=(
CUTTER_ENABLE_PYTHON=true
PREFIX=\'${EPREFIX}/usr\'
)
eqmake5 "${myqmakeargs[@]}" src
}
src_install() {
emake INSTALL_ROOT="${D}" install
}
pkg_postinst() {
xdg_icon_cache_update
}
pkg_postrm() {
xdg_icon_cache_update
}