You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/edb-debugger/edb-debugger-9999.ebuild

50 lines
932 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit cmake git-r3
DESCRIPTION="edb is a cross platform x86/x86-64 debugger, inspired by Ollydbg"
HOMEPAGE="https://github.com/eteran/edb-debugger"
EGIT_REPO_URI="https://github.com/eteran/edb-debugger.git"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS=""
IUSE="graphviz jumbo-build"
RDEPEND="
dev-libs/capstone:=
dev-libs/double-conversion
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtnetwork:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
dev-qt/qtxmlpatterns:5
graphviz? ( media-gfx/graphviz )
"
DEPEND="
dev-libs/boost
virtual/pkgconfig
${RDEPEND}
"
src_prepare() {
if ! use graphviz; then
sed -i -e '/pkg_check_modules(GRAPHVIZ/d' CMakeLists.txt || die
fi
cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
-DBUILD_JUMBO=$(usex jumbo-build)
)
cmake_src_configure
}