You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/gcovr/gcovr-4.2.ebuild

45 lines
940 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8} )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
DESCRIPTION="A Python script for summarizing gcov data"
HOMEPAGE="https://github.com/gcovr/gcovr"
SRC_URI="https://github.com/gcovr/gcovr/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RDEPEND="
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
"
BDEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/PyUtilib[${PYTHON_USEDEP}]
)
"
# tests fail on gcc newer than 5.8
# https://github.com/gcovr/gcovr/issues/206
RESTRICT="test"
distutils_enable_tests pytest
python_test() {
distutils_install_for_testing
local -x PATH="${TEST_DIR}/scripts:${PATH}" \
PYTHONPATH="${TEST_DIR}/lib"
pytest -vv gcovr || die "Tests fail with ${EPYTHON}"
}