You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/kyua/kyua-0.13-r2.ebuild

32 lines
632 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DESCRIPTION="Testing framework for infrastructure software"
HOMEPAGE="https://github.com/jmmv/kyua"
SRC_URI="https://github.com/jmmv/kyua/releases/download/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos"
IUSE="test"
# Tests fail
RESTRICT="test"
RDEPEND="
dev-db/sqlite:3
dev-libs/atf
dev-lua/lutok
"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-libs/atf )
"
src_install() {
default
rm -r "${ED%/}"/usr/tests || die
}