You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/lttng-ust/lttng-ust-2.8.1.ebuild

31 lines
661 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit autotools versionator
MY_P="${P/_rc/-rc}"
MY_SLOT="$(get_version_component_range 1-2)"
DESCRIPTION="Linux Trace Toolkit - UST library"
HOMEPAGE="https://lttng.org"
SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0/${MY_SLOT}"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
IUSE="examples"
DEPEND="dev-libs/userspace-rcu:="
RDEPEND="${DEPEND}"
S="${WORKDIR}"/${MY_P}
src_prepare() {
if ! use examples; then
sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
fi
eautoreconf
}