You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/patchelf/patchelf-0.11.ebuild

33 lines
657 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
HOMEPAGE="https://nixos.org/patchelf.html"
SRC_URI="https://nixos.org/releases/${PN}/${P}/${P}.tar.bz2"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-3"
S="${WORKDIR}/${P}.20200609.d6b2a72"
src_prepare() {
default
rm src/elf.h || die
sed -i \
-e 's:-Werror::g' \
configure.ac || die
eautoreconf
}
src_test() {
emake check \
CFLAGS+=" -no-pie" \
CXXFLAGS+=" -no-pie"
}