You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/pkgdiff/pkgdiff-1.7.2.ebuild

33 lines
608 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Package Changes Analyzer (pkgdiff)"
HOMEPAGE="https://github.com/lvc/pkgdiff"
SRC_URI="https://github.com/lvc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64"
DEPEND=">=dev-lang/perl-5"
RDEPEND="${DEPEND}
app-text/wdiff
dev-perl/File-LibMagic
sys-apps/diffutils
sys-apps/gawk
sys-devel/binutils
"
src_compile() {
:
}
PREFIX="/usr"
src_install() {
dodir ${PREFIX}
perl Makefile.pl -install --destdir "${ED}" || die "install failed"
}