You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/premake/premake-4.3-r1.ebuild

31 lines
539 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit versionator epatch
DESCRIPTION="A makefile generation tool"
HOMEPAGE="http://industriousone.com/premake"
SRC_URI="mirror://sourceforge/premake/${P}-src.zip"
LICENSE="BSD"
SLOT=$(get_major_version)
KEYWORDS="amd64 ppc x86"
IUSE=""
DEPEND="app-arch/unzip"
RDEPEND=""
src_prepare() {
epatch "${FILESDIR}/archless.patch"
}
src_compile() {
emake -C build/gmake.unix/
}
src_install() {
dobin bin/release/premake4
}