You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/samurai/samurai-1.2-r1.ebuild

27 lines
651 B

# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="ninja-compatible build tool written in C"
HOMEPAGE="https://github.com/michaelforney/samurai"
if [[ "${PV}" == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/michaelforney/samurai.git"
else
SRC_URI="https://github.com/michaelforney/samurai/releases/download/${PV}/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
LICENSE="ISC Apache-2.0 MIT"
SLOT="0"
PATCHES=(
"${FILESDIR}/${P}-null_pointer_fix.patch" #786957
)
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
dodoc README.md
}