You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/shellcheck-bin/shellcheck-bin-0.7.1.ebuild

31 lines
683 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
MY_PN=${PN/-bin/}
BASE_URI="https://github.com/koalaman/${MY_PN}/releases/download/v${PV}/${MY_PN}-v${PV}.linux"
DESCRIPTION="Shell script analysis tool (binary package)"
HOMEPAGE="https://www.shellcheck.net/"
SRC_URI="
amd64? ( "${BASE_URI}".x86_64.tar.xz )
arm? ( "${BASE_URI}".armv6hf.tar.xz )
arm64? ( "${BASE_URI}".aarch64.tar.xz )
"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64"
DEPEND="!dev-util/shellcheck"
RDEPEND="${DEPEND}"
QA_PREBUILT="/usr/bin/shellcheck"
S="${WORKDIR}/${MY_PN}-v${PV}"
src_install() {
dobin shellcheck
einstalldocs
}