You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-util/splint/splint-3.1.2-r2.ebuild

52 lines
1.1 KiB

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="Check C programs for vulnerabilities and programming mistakes"
HOMEPAGE="http://lclint.cs.virginia.edu/"
SRC_URI="http://www.splint.org/downloads/${P}.src.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~ppc-macos ~x64-macos"
DEPEND="sys-devel/flex"
PATCHES=(
"${FILESDIR}"/${PN}-3.1.2-musl.patch
)
src_prepare() {
default
# verbose compiler calls
sed -i -e '/Compiling/d' src/Makefile.am || die
# automake complains about trailing \
sed -i -e '1600d' test/Makefile.am || die
# do not install these header files twice
sed -i -e '/\$(UnixHeaders)/s|stdio.h stdlib.h||g' lib/Makefile.am || die
eautoreconf
}
src_configure() {
# We do not need bison/yacc at all here
# We definitely need libfl
BISON=no LEXLIB=-lfl econf
}
src_compile() {
local subdir
# skip test/ subdir
for subdir in src lib imports doc; do
emake -j1 -C ${subdir}
done
}
src_test() {
emake -C test
}