You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-vcs/rcs/rcs-5.9.4.ebuild

48 lines
878 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
inherit flag-o-matic
DESCRIPTION="Revision Control System"
HOMEPAGE="https://www.gnu.org/software/rcs/"
SRC_URI="mirror://gnu/rcs/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
IUSE="doc"
RDEPEND="
sys-apps/diffutils
sys-apps/ed"
DEPEND="${RDEPEND}"
src_prepare() {
sed -i -e '/gets is a security hole/d' \
lib/stdio.in.h || die
}
src_configure() {
append-flags -std=gnu99
econf
}
src_test() {
emake check
}
src_install() {
emake DESTDIR="${D}" install
dodoc ChangeLog NEWS README
if use doc; then
emake -C doc html
rm -R "${ED}/usr/share/doc/rcs"
mv doc/rcs.html doc/html
dodoc -r doc/html/
fi
}