You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild

36 lines
679 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit toolchain-funcs
DESCRIPTION="Space invaders clone, using ncurses library"
HOMEPAGE="https://packages.gentoo.org/package/games-arcade/ascii-invaders"
SRC_URI="mirror://gentoo/invaders${PV}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~mips ~ppc64 ~x86 ~ppc-macos"
IUSE=""
RDEPEND="sys-libs/ncurses:0"
DEPEND="${RDEPEND}
virtual/pkgconfig"
S="${WORKDIR}/invaders"
src_prepare() {
default
rm -f Makefile
}
src_compile() {
emake LDLIBS="$($(tc-getPKG_CONFIG) ncurses --libs)" invaders
}
src_install() {
newbin invaders ${PN}
einstalldocs
}