You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-arcade/gnujump/gnujump-1.0.8-r1.ebuild

36 lines
645 B

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit desktop flag-o-matic
DESCRIPTION="Xjump clone with added features"
HOMEPAGE="http://gnujump.es.gnu.org"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="media-libs/libsdl[sound,video]
media-libs/sdl-image[png]
media-libs/sdl-mixer[vorbis]
virtual/opengl
x11-libs/libX11
"
RDEPEND="${DEPEND}"
src_prepare() {
default
append-libs -lm
}
src_install() {
default
einstalldocs
newicon skins/xjump/hero1.0.png ${PN}.png
make_desktop_entry ${PN} "GNUjump"
}