You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-puzzle/braincurses/braincurses-0.5b-r1.ebuild

35 lines
643 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DESCRIPTION="An ncurses-based mastermind clone"
HOMEPAGE="https://github.com/bderrly/braincurses"
SRC_URI="mirror://sourceforge/braincurses/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
IUSE=""
DEPEND=""
RDEPEND=""
src_prepare() {
default
eapply "${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/${P}-as-needed.patch
# fix buffer overflow (bug #301033)
sed -i \
-e 's/guessLabel\[2/guessLabel[3/' \
curses/windows.cpp \
|| die 'sed failed'
}
src_install() {
dobin braincurses
einstalldocs
}