You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-puzzle/gweled/gweled-0.9.1-r2.ebuild

38 lines
696 B

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit autotools flag-o-matic
DESCRIPTION="Bejeweled clone game"
HOMEPAGE="http://www.gweled.org/"
SRC_URI="https://launchpad.net/gweled/trunk/${PV}/+download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="
x11-libs/gtk+:2
media-libs/libmikmod
gnome-base/librsvg:2
"
DEPEND="${RDEPEND}
virtual/pkgconfig
"
src_prepare() {
default
eapply "${FILESDIR}"/${P}-gentoo.patch
mv configure.in configure.ac || die
eautoreconf
}
src_configure() {
filter-flags -fomit-frame-pointer
append-ldflags -Wl,--export-dynamic
econf --disable-setgid
}