You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-puzzle/swell-foop/swell-foop-3.34.1.ebuild

48 lines
861 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit gnome.org gnome2-utils meson vala xdg
DESCRIPTION="Clear the screen by removing groups of colored and shaped tiles"
HOMEPAGE="https://wiki.gnome.org/Apps/Swell%20Foop"
LICENSE="GPL-2+ FDL-1.1+"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE=""
RDEPEND="
>=dev-libs/glib-2.36:2
>=x11-libs/gtk+-3.12:3
>=media-libs/clutter-1.14.0:1.0
>=media-libs/clutter-gtk-1.5.0:1.0
"
DEPEND="${RDEPEND}"
BDEPEND="
dev-libs/appstream-glib
dev-util/itstool
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
$(vala_depend)
"
PATCHES=(
"${FILESDIR}"/3.34.1-fix-vala-0.50.patch
)
src_prepare() {
xdg_src_prepare
vala_src_prepare
}
pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update
}
pkg_postrm() {
xdg_pkg_postrm
gnome2_schemas_update
}