You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-puzzle/textmaze/textmaze-1.2-r1.ebuild

32 lines
589 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
MY_P=${PN}_v${PV}
DESCRIPTION="An ncurses-based maze solving game written in Perl"
HOMEPAGE="https://robobunny.com/projects/textmaze/html/"
SRC_URI="https://www.robobunny.com/projects/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="dev-perl/Curses"
DEPEND=""
S="${WORKDIR}/TextMaze"
src_prepare() {
default
sed -i \
-e "s#/usr/local/bin/perl#/usr/bin/perl#" \
textmaze || die
}
src_install() {
dobin textmaze
einstalldocs
}