You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-roguelike/powder/powder-117-r1.ebuild

40 lines
919 B

# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit flag-o-matic
MY_P=${P/-/}_src
DESCRIPTION="A game in the genre of Rogue, Nethack, and Diablo. Emphasis is on tactical play"
HOMEPAGE="http://www.zincland.com/powder/"
SRC_URI="http://www.zincland.com/powder/release/${MY_P}.tar.gz"
LICENSE="CC-Sampling-Plus-1.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="media-libs/libsdl[video]"
RDEPEND=${DEPEND}
S=${WORKDIR}/${MY_P}
PATCHES=( "${FILESDIR}"/${PN}-117-gcc6.patch )
src_compile() {
append-cxxflags -DCHANGE_WORK_DIRECTORY
emake -C port/linux premake
emake -C port/linux powder
}
src_install() {
dobin port/linux/${PN}
dodoc README.TXT CREDITS.TXT
}
pkg_postinst() {
elog "While the highscore is kept, save games are never preserved between"
elog "versions. Please wait until your current character dies before upgrading."
}