You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-sports/bygfoot/bygfoot-2.3.2-r1.ebuild

44 lines
765 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit desktop vcs-clean
DESCRIPTION="GTK+2 Soccer Management Game"
HOMEPAGE="http://bygfoot.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
app-arch/zip
media-libs/freetype:2
x11-libs/gtk+:2
virtual/libintl"
DEPEND="${RDEPEND}"
BDEPEND="
sys-devel/gettext
virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-Makefile.patch
"${FILESDIR}"/${P}-fno-common.patch
)
src_configure() {
econf --disable-gstreamer
}
src_install() {
default
dodoc UPDATE
esvn_clean "${D}"
newicon support_files/pixmaps/bygfoot_icon.png ${PN}.png
make_desktop_entry ${PN} Bygfoot
}